const regex = /<a href=\S+\s/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<a href=\\S+\\s', 'gm')
const str = `<a href="/p76643761#p76643761active That's nice`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);