re = /<a href=\S+\s/m
str = '<a href="/p76643761#p76643761active That\'s nice'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result