import re
regex = re.compile(r"<a href=\S+\s", flags=re.MULTILINE)
test_str = "<a href=\"/p76643761#p76643761active That's nice"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)