use strict;
my $str = '<a href="/p76643761#p76643761active That\'s nice';
my $regex = qr/<a href=\S+\s/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";