import re
regex = re.compile((r"<\s*span[^>]*>(.*?)<.*?\/span>\n"), flags=re.MULTILINE)
test_str = (" <div class=\"list-group\">\n"
" <input type=\"checkbox\" dataid=\"101\" />\n"
" <a href=\"techno1\">2023</a>\n"
" <span> 615 <a href=\"techno\"><i class=\"fa fa-chevron-circle-right\"></i></a></span>\n"
" </div>\n"
" \n"
" <div class=\"list-group\">\n"
" <input type=\"checkbox\" dataid=\"102\" />\n"
" <a href=\"techno2\">2023</a>\n"
" <span> 715 <a href=\"techno\"><i class=\"fa fa-chevron-circle-right\"></i></a></span>\n"
" </div>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")