#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?u)([\.\,\?!;:\(\)\(\)\{\}\-\+`\\\^\[\]\^"]\S|(\'\S*\'))"
Local $sString = "ee maa i dasda!s2di []adasd"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")