re = /([\.\,\?!;:\(\)\(\)\{\}\-\+`\\\^\[\]\^"]\S|(\'\S*\'))/
str = 'ee maa i dasda!s2di []adasd'
# Print the match result
str.match(re) do |match|
puts match.to_s
end