using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\.\,\?!;:\(\)\(\)\{\}\-\+`\\\^\[\]\^""]\S|(\'\S*\'))";
string input = @"ee maa i dasda!s2di []adasd";
RegexOptions options = RegexOptions.CultureInvariant;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}