package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([\.\,\?!;:\(\)\(\)\{\}\-\+`\\\^\[\]\^"]\S|(\'\S*\'))`)
var str = `ee maa i dasda!s2di []adasd`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}