#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^\s+|\s*"\s*|\s*<.*|\S+@\S+|\s*\(\s*|\s*\)\s*"
Local $sString = "dano@xpotential.com (notes here)" & @CRLF & _
" John Doe" & @CRLF & _
"" John Doe " <johndoe@example.com>"
Local $sSubst = "\t"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)