package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\S+\r?\n\s*\S+`)
var str = `K MAT NSA7143*USA 3 AIRLINES TOWN LOSA20 09:30AM 10:30PM ED S *ZKV
DMG`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}