re = /\S+\r?\n\s*\S+/
str = 'K MAT NSA7143*USA 3 AIRLINES TOWN LOSA20 09:30AM 10:30PM ED S *ZKV
DMG'
# Print the match result
str.match(re) do |match|
puts match.to_s
end