import Foundation
let pattern = #"\S+\r?\n\s*\S+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
K MAT NSA7143*USA 3 AIRLINES TOWN LOSA20 09:30AM 10:30PM ED S *ZKV
DMG
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}