const regex = /\S+\r?\n\s*\S+/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\S+\\r?\\n\\s*\\S+', '')
const str = `K MAT NSA7143*USA 3 AIRLINES TOWN LOSA20 09:30AM 10:30PM ED S *ZKV
DMG`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}