#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(\S{1,}\s\d{1,}\s)(Etage:\d{1,}\s\w{1,}\s)(Raum:\d{1,})"
Local $sString = "Jägerallee 23 Etage:1 OG Raum:4114"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")