re = /(\S{1,}\s\d{1,}\s)(Etage:\d{1,}\s\w{1,}\s)(Raum:\d{1,})/i
str = 'Jägerallee 23 Etage:1 OG Raum:4114'
# Print the match result
str.match(re) do |match|
puts match.to_s
end