#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(@[^@]+?)@[^ ]+?(?= )"
Local $sString = "Example 1 @abc@xy-example.com and @xyz@abc.com Example 2"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)