use strict;
my $str = 'Example 1 @abc@xy-example.com and @xyz@abc.com Example 2';
my $regex = qr/(@[^@]+?)@[^ ]+?(?= )/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";