re = /(@[^@]+?)@[^ ]+?(?= )/m
str = 'Example 1 @abc@xy-example.com and @xyz@abc.com Example 2'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result