$re = '/(@[^@]+?)@[^ ]+?(?= )/m';
$str = 'Example 1 @abc@xy-example.com and @xyz@abc.com Example 2';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;