import Foundation
let pattern = #"(@[^@]+?)@[^ ]+?(?= )"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"Example 1 @abc@xy-example.com and @xyz@abc.com Example 2"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)