#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([0-9a-fA-F]+\.){4}"
Local $sString = "Gigabyte G1 Gaming Edition" & @CRLF & _
"AgentX20 84.04.2F.00.80 - 2014-10-31 build date" & @CRLF & _
"Kray - 84.04.28.00.4D - 2014-10-21" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")