use strict;
my $str = 'Gigabyte G1 Gaming Edition
AgentX20 84.04.2F.00.80 - 2014-10-31 build date
Kray - 84.04.28.00.4D - 2014-10-21
';
my $regex = qr/([0-9a-fA-F]+\.){4}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}