$re = '/([0-9a-fA-F]+\.){4}/m';
$str = 'Gigabyte G1 Gaming Edition
AgentX20 84.04.2F.00.80 - 2014-10-31 build date
Kray - 84.04.28.00.4D - 2014-10-21
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);