re = /([0-9a-fA-F]+\.){4}/m
str = 'Gigabyte G1 Gaming Edition
AgentX20 84.04.2F.00.80 - 2014-10-31 build date
Kray - 84.04.28.00.4D - 2014-10-21
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end