// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([0-9a-fA-F]+\.){4}").unwrap();
let string = "Gigabyte G1 Gaming Edition
AgentX20 84.04.2F.00.80 - 2014-10-31 build date
Kray - 84.04.28.00.4D - 2014-10-21
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}