#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^AB[A-Z]*[0-9][A-Z0-9]*$"
Local $sString = "AB1AX" & @CRLF & _
"ABA1X" & @CRLF & _
"AB09" & @CRLF & _
"ABAXX" & @CRLF & _
"ABAEX" & @CRLF & _
"BBAE1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")