import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^AB[A-Z]*[0-9][A-Z0-9]*$";
final String string = "AB1AX\n"
+ "ABA1X\n"
+ "AB09\n"
+ "ABAXX\n"
+ "ABAEX\n"
+ "BBAE1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}