// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^AB[A-Z]*[0-9][A-Z0-9]*$").unwrap();
let string = "AB1AX
ABA1X
AB09
ABAXX
ABAEX
BBAE1";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}