using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^AB[A-Z]*[0-9][A-Z0-9]*$";
string input = @"AB1AX
ABA1X
AB09
ABAXX
ABAEX
BBAE1";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}