$re = '/^AB[A-Z]*[0-9][A-Z0-9]*$/m';
$str = 'AB1AX
ABA1X
AB09
ABAXX
ABAEX
BBAE1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);