const regex = /((<(.|\n)+?>)?[^=])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((<(.|\\n)+?>)?[^=])', 'g')
const str = `<html style='aklfhnakfn'>This is test content
<head font="13"> dummy head </head>
<p> This is a sample?<a href="www.google.com"> a=b=c=d test release </a> </p>
<p> Dummy a = b = c= d </p>
</html>`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);