# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((<(.|\n)+?>)?[^=])"
test_str = ("<html style='aklfhnakfn'>This is test content \n"
"<head font=\"13\"> dummy head </head>\n"
"<p> This is a sample?<a href=\"www.google.com\"> a=b=c=d test release </a> </p>\n"
"<p> Dummy a = b = c= d </p>\n"
"</html>")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.