#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[0-9,]+\s[KB]+"
Local $sString = "SAVE.|NCOM|NG,418745716MAR2021(1).ASC|I.EPIN.TXT ./ 248,768 KB 16/03/2021 4:13:20 AM" & @CRLF & _
"SAVE.|NCOM|NG,418745716MAR20…248,768 KB 16/03/2021 4:13:20 AM"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")