// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[0-9,]+\s[KB]+").unwrap();
let string = "SAVE.|NCOM|NG,418745716MAR2021(1).ASC|I.EPIN.TXT ./ 248,768 KB 16/03/2021 4:13:20 AM
SAVE.|NCOM|NG,418745716MAR20…248,768 KB 16/03/2021 4:13:20 AM";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}