use strict;
my $str = 'SAVE.|NCOM|NG,418745716MAR2021(1).ASC|I.EPIN.TXT ./ 248,768 KB 16/03/2021 4:13:20 AM
SAVE.|NCOM|NG,418745716MAR20…248,768 KB 16/03/2021 4:13:20 AM';
my $regex = qr/[0-9,]+\s[KB]+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}