$re = '/[0-9,]+\s[KB]+/m';
$str = 'SAVE.|NCOM|NG,418745716MAR2021(1).ASC|I.EPIN.TXT ./ 248,768 KB 16/03/2021 4:13:20 AM
SAVE.|NCOM|NG,418745716MAR20…248,768 KB 16/03/2021 4:13:20 AM';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);