import re
regex = re.compile(r"[0-9,]+\s[KB]+", flags=re.MULTILINE)
test_str = ("SAVE.|NCOM|NG,418745716MAR2021(1).ASC|I.EPIN.TXT ./ 248,768 KB 16/03/2021 4:13:20 AM\n"
"SAVE.|NCOM|NG,418745716MAR20…248,768 KB 16/03/2021 4:13:20 AM")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")