# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\n\n)-\s*(?!.*(?:(?<!-)\n-|\n-))/$1/gm;t' <<< "Here are few example strings where a leading dash character should be removed (note newlines):
- Lovely day.
- Lovely day-night cycle.
- Lovely day.
Isn't it?
- lovely day - isn't it?
- Lovely day -
isn't it?
Here are few example strings where leading dash character(s) should be retained (note the 2nd example, it might be tricky):
- Lovely day.
- Yeah, isn't it?
Lovely day.
- Yeah, isn't it?
- lovely day - isn't it?
- Yes.
- Lovely day for a -
- Walk?
"