using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\n\n)-\s*(?!.*(?:(?<!-)\n-|\n-))";
string substitution = @"$1";
string input = @"Here are few example strings where a leading dash character should be removed (note newlines):
- Lovely day.
- Lovely day-night cycle.
- Lovely day.
Isn't it?
- lovely day - isn't it?
- Lovely day -
isn't it?
Here are few example strings where leading dash character(s) should be retained (note the 2nd example, it might be tricky):
- Lovely day.
- Yeah, isn't it?
Lovely day.
- Yeah, isn't it?
- lovely day - isn't it?
- Yes.
- Lovely day for a -
- Walk?
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}