import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\n\\n)-\\s*(?!.*(?:(?<!-)\\n-|\\n-))";
final String string = "Here are few example strings where a leading dash character should be removed (note newlines):\n\n"
+ "- Lovely day.\n\n"
+ "- Lovely day-night cycle.\n\n"
+ "- Lovely day.\n"
+ "Isn't it?\n\n"
+ "- lovely day - isn't it?\n\n"
+ "- Lovely day -\n"
+ "isn't it?\n\n"
+ "Here are few example strings where leading dash character(s) should be retained (note the 2nd example, it might be tricky):\n\n"
+ "- Lovely day.\n"
+ "- Yeah, isn't it?\n\n"
+ "Lovely day.\n"
+ "- Yeah, isn't it?\n\n"
+ "- lovely day - isn't it?\n"
+ "- Yes.\n\n"
+ "- Lovely day for a -\n"
+ "- Walk?\n";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}