import Foundation
let pattern = #"(\n\n)-\s*(?!.*(?:(?<!-)\n-|\n-))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Here are few example strings where a leading dash character should be removed (note newlines):
- Lovely day.
- Lovely day-night cycle.
- Lovely day.
Isn't it?
- lovely day - isn't it?
- Lovely day -
isn't it?
Here are few example strings where leading dash character(s) should be retained (note the 2nd example, it might be tricky):
- Lovely day.
- Yeah, isn't it?
Lovely day.
- Yeah, isn't it?
- lovely day - isn't it?
- Yes.
- Lovely day for a -
- Walk?
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)