use strict;
my $str = 'Here are few example strings where a leading dash character should be removed (note newlines):
- Lovely day.
- Lovely day-night cycle.
- Lovely day.
Isn\'t it?
- lovely day - isn\'t it?
- Lovely day -
isn\'t it?
Here are few example strings where leading dash character(s) should be retained (note the 2nd example, it might be tricky):
- Lovely day.
- Yeah, isn\'t it?
Lovely day.
- Yeah, isn\'t it?
- lovely day - isn\'t it?
- Yes.
- Lovely day for a -
- Walk?
';
my $regex = qr/(\n\n)-\s*(?!.*(?:(?<!-)\n-|\n-))/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";