# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=[a-z])\d+\b//gm;t' <<< "Senku Ishigami is charecter from a manga series98 onging since 2017."