$re = '/(?<=[a-z])\d+\b/m';
$str = 'Senku Ishigami is charecter from a manga series98 onging since 2017.';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;