re = /(?<=[a-z])\d+\b/m
str = 'Senku Ishigami is charecter from a manga series98 onging since 2017.'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result