const regex = new RegExp('(?<=[a-z])\\d+\\b', 'gm')
const str = `Senku Ishigami is charecter from a manga series98 onging since 2017.`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);