using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*)\h+(\()?world(?(2)\))";
string substitution = @"$1";
string input = @"this is my world, not my (world)
this is my world, not my world
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}