package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.*)\h+(\()?world(?(2)\))`)
var str = `this is my world, not my (world)
this is my world, not my world
`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}