$re = '/(.*)\h+(\()?world(?(2)\))/m';
$str = 'this is my world, not my (world)
this is my world, not my world
';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;